HTML, Excel, Word, SEOОсновы Excel ⇒ Операции с текстом Excel 2007

ОСНОВЫ EXCEL

Учебник Excel
Перемещение по листу и выделение ячеек
Ввод данных
Создание формул
Знакомство с функциями
Имена ячеек и диапазонов
Массивы
Форматирование. Назначение и удаление форматов
Форматирование чисел и текста
Маленькие секреты форматирования
Заканчиваем пользовательский формат
Выравнивание содержимого ячеек
Изменение шрифта
Использование границ и заливки
Условное форматирование и объединение ячеек
Установка параметров для редактирования
Использование мыши при вводе и редактировании
Заполнение рядов с помощью мыши
Вырезание и вставка ячеек
Функции. Синтаксис функций
Ввод функций
Математические функции
Текстовые функции
Функции для работы с элементами строк
Логические функции
Excel 2007
Интерфейс Excel 2007
Проверка вводимых данных
Условное форматирование
Сортировка и фильтрация
Связанные таблицы
Работа с диаграммами
Что такое сводные таблицы
Как создать сводную таблицу
Форматирование сводной таблицы
Анализ данных сводной таблицы
Создание сводной диаграммы
Вопрос-Ответ
Работа с датами
Вопросы по датам
Ошибки Excel
Защита данных Excel
Шаблоны Excel
Сортировка в Excel
Операции с текстом
Форматирование диаграмм
Сохранение диаграмм
Консолидация данных
Импорт данных в Excel
Поиск данных в таблицах
Операции с формулами массивов
Экспорт данных из Excel
Создание колонтитулов в Excel

 
Сабмит сайта в каталоги

Операции с текстом Excel 2007


Автор: Индык Игорь Викторович
e-mail: exelentc@yandex.ru


Я выгрузил в формат Эксель большую базу данных, но в таблице есть много непечатаемых символов. Их можно удалить все одновременно?


 

Для решения такой задачи Excel содержит функцию ПЕЧСИМВ.


 

Для удаления непечатаемых символов из текста в ячейке А1, введите формулу

=ПЕЧСИМВ(А1).

Соответственно, если необходимо очистить от таких символов большую таблицу, проще всего на новом листе той же рабочей книги создать копию этой таблицы, растянув указанную формулу для всех соответствующих полей основной таблицы.


 
 

У меня есть файл таблицы в виде форматированного текста с пробелами - разделителями. Как мне удалить пробелы из таблицы?


 

Если необходимо, чтобы между отдельными словами текста оставался пробел (слова текста не должны сливаться), можно воспользоваться функцией СЖПРОБЕЛЫ. Если пробелы нужно удалить в объемной таблице, лучше всего создать дубликат этой таблицы с использованием функции СЖПРОБЕЛЫ, как это было описано в предыдущем ответе.


 

Если же нужно удалить все пробелы без исключения, можно воспользоваться стандартной функцией Excel поиска и замены текста. Вызовите окно Найти и заменить комбинацией клавиш CTRL+H (или CTRL+F, а потом перейдите на вкладку Заменить), в поле Найти: введите пробел, а поле Заменить на: оставьте незаполненным. После выполнения этой команды все пробелы будут убраны.


 

Так же можно воспользоваться функцией рабочего листа ПОДСТАВИТЬ, которая работает аналогичным образом.


 

В Ворде можно легко сделать буквы текста прописными комбинацией Shift+F3. А в Екселе она не работает. Какой комбинацией можна это сделать в Екселе?


 

Замена строчных букв прописными в Excel'е проводится с помощью функции ПРОПИСН. Для замены букв текста в ячейке А1 на прописные достаточно воспользоваться формулой:

=ПРОПИСН(А1)

Мне нужно увеличить не все буквы, а только первые!


 

Для решения этой проблемы в Excel'е используется функция рабочего листа ПРОПНАЧ. Она делает первую букву каждого слова в тексте прописной, а все остальные буквы - строчными.


 

Вышеприведённые функции обработки текста можно комбинировать. Например, для приведения в порядок таблицы, которая содержит неправильно расставленные прописные/строчные буквы и излишние пробелы, можно использовать следующую формулу:

=СЖПРОБЕЛЫ(ПРОПНАЧ(A1))

Результаты её работы можно увидеть здесь:


 
 

У меня в таблице фамилии и инициалы находятся в разных колонках. Как их соединить в одной ячейке?


 

Для объединения нескольких текстовых полей в одно можно использовать функцию СЦЕПИТЬ или операнд &.


 

Формула с использованием функции СЦЕПИТЬ будет иметь следующий вид:

=СЦЕПИТЬ(A1;" ";B1;" ";C1)

 
 

Другой вариант решения проблемы:

=A1&" "&B1&" "&C1

 
 

Обратите внимание, что и в том и в другом случае в структуре формулы необходимо вводить пробелы между отдельными словами, иначе текст из трёх ячеек будет соединен в одно слово.


 

Нужна Ваша помощь. Чтобы убрать из ячейки запятую я использую формулу

=ПОДСТАВИТЬ(L8;",";""), 

чтобы убрать плюс

=ПОДСТАВИТЬ(L8;"+";""), 

чтобы убрать минус

=ПОДСТАВИТЬ(L8;"-";""), 

чтобы убрать знак равенства

=ПОДСТАВИТЬ(L8;"=";""). 

Подскажите, можно ли объединить эти четыре формулы в одну, и как.


 

Поскольку речь идет об обработке набора текстовых символов (другими словами - "куска" текста) самым простым способом будет вложить эти четыре формулы одна в другую по принципу матрешки:

=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(А1;"=";"");"+";"");"-";"");",";"")

 
 

Посоветуйте, каким образом вывести из даты название дня недели или месяца?


 

Для того чтобы вместо числа вывести название дня недели или месяца, необходимо совместить функцию ТЕКСТ и формат выведения данных.


 

Например, если у нас в ячейке А1 выводится нужная нам дата, то для получения названия этого дня необходимо воспользоваться формулой:

=ТЕКСТ(A1;"ДДДД") 

где ДДДД - встроенный формат отображения полного названия дня недели.


 
 

Соответственно для месяца эта формула будет иметь вид:

=ТЕКСТ(A1;"ММММ")

 

Совет. Для того чтобы вывести название для недели с большой буквы, воспользуйтесь функцией ПРОПНАЧ:

=ПРОПНАЧ(ТЕКСТ(A1;"ДДДД"))

 

А возможно вывести название месяца в родительном падеже? Не январь, а января и т.д.?


 

Да, но для этого нужно применить иной подход, с использованием функции ВЫБОР и функции МЕСЯЦ:

=ВЫБОР(МЕСЯЦ($A$1);"января";"февраля";"марта";"апреля"; "мая";"июня";"июля";"августа";"сентября";"октября";"ноября";"декабря") 

Функция МЕСЯЦ извлекает из введённой даты номер месяца, а функция ВЫБОР заменяет это число заранее указанным аргументом.


 

В начало страницы



В начало страницы